Лицензионное соглашение и ограниченная гарантия

Next

Настоящее лицензионное соглашение (далее «соглашение») заключается между Вами (физическим или юридическим лицом) и ОАО «Главный информационно-вычислительный центр Москвы» (далее ОАО «ГИВЦ Москвы») относительно объекта лицензирования (далее «Программа»), который может включать в себя компоненты программного обеспечения, записанного на соответствующих носителях, печатные материалы и "встроенную" или "электронную" документацию. Устанавливая, копируя или иным образом используя Программу, Вы, тем самым, принимаете на себя условия настоящего соглашения. Если Вы не принимаете условий данного соглашения, то Вы не имеете права использовать данную Программу и его следует незамедлительно вернуть продавцу и получить обратно уплаченные деньги.

Это лицензионное соглашение гарантирует полное взаимопонимание между Вами, конечным пользователем Программы, и ОАО «ГИВЦ Москвы», и может изменяться или дополняться только в письменном виде, подписанном обеими сторонами. НИКАКОЙ ПРОДАВЕЦ, ДИСТРИБУТОР, ДИЛЕР, РОЗНИЧНЫЙ ТОРГОВЕЦ, КОММЕРЧЕСКОЕ ИЛИ ДРУГОЕ ЛИЦО НЕ УПОЛНОМОЧЕНЫ ИЗМЕНЯТЬ ДАННОЕ СОГЛАШЕНИЕ ИЛИ ДАВАТЬ ЛЮБЫЕ ДРУГИЕ ГАРАНТИИ ИЛИ ОБЕЩАНИЯ, ЯВЛЯЮЩИЕСЯ ОТЛИЧНЫМИ ОТ ГАРАНТИЙ ИЛИ ОБЕЩАНИЙ, УСТАНОВЛЕННЫХ В ДАННОМ СОГЛАШЕНИИ.

Программа защищена законодательством Российской Федерации, регулирующим отношения авторского права. Программа лицензируется, а не продается.

1. ОБЪЕМ ОДНОЙ НЕИСКЛЮЧИТЕЛЬНОЙ ЛИЦЕНЗИИ.

Настоящее соглашение дает Вам нижеследующие права:
· Установка и использование. ОАО «ГИВЦ Москвы» предоставляет Вам право установить на компьютер и использовать одну копию Программы, а также разрешается создание одной резервной копии программного обеспечения.
· Распространение. Распространение Вами Программы в коммерческих или иных целях возможно в соответствии с условиями отдельного лицензионного соглашения. За более подробными сведениями обращайтесь в ОАО «ГИВЦ Москвы».

2. ПРОЧИЕ ПРАВА И ОГРАНИЧЕНИЯ.

· Запрет на вскрытие технологии и декомпиляцию. Запрещается вскрывать технологию и декомпилировать программное обеспечение за исключением случая и только в той степени, когда такие действия явно разрешены действующим законодательством, несмотря на наличие в лицензионном соглашении данного ограничения.
· Временное пользование. Запрещается предоставлять Программу третьим лицам во временное пользование, в т. ч. безвозмездное, сдавать в аренду или в прокат.
· Разделение программы. Программа лицензируется как единое целое. Ее нельзя разделять на части для использования на нескольких компьютерах.
· Передача программы. Разрешается навсегда уступить все свои права по настоящему соглашению при условии, что Вы не оставляете у себя никаких копий, передаете всю Программу (включая ее составные части, носители и печатные материалы, любые обновления, настоящее соглашение и сертификаты подлинности, если таковые имеются), а получатель соглашается на условия данного соглашения. Если Программа является обновлением, то любая передача должна включать в себя все предыдущие версии программы.
· Техническое обслуживание. ОАО «ГИВЦ Москвы» может оказывать услуги по техническому обслуживанию Программы (далее «техническое обслуживание»). Любые дополнительные программы и исходные тексты, переданные Вам в порядке оказания услуг по техническому обслуживанию, должны рассматриваться как составная часть программного обеспечения и подпадают, таким образом, под действие ограничений и условий данного соглашения. Технические данные, которые сообщаются службе технического обслуживания в ходе обращения, могут быть использованы ОАО «ГИВЦ Москвы» для внутренних целей, включая техническое обслуживание и разработку программного обеспечения. ОАО «ГИВЦ Москвы» не будет использовать данные сведения в форме, раскрывающей Вас лично.
· Гарантийный срок. После Вашей регистрации в качестве легального пользователя Вы имеете право на получение технической поддержки в течение одного года. Ваш срок получения поддержки начинается в день, когда Вы купили Программу, и заканчивается через один год, прошедший со дня ее покупки в ОАО «ГИВЦ Москвы» или у его официального дилера. В течение гарантийного срока ОАО «ГИВЦ Москвы» предоставляет возможность получения консультаций по использованию Программы по телефону и бесплатное обновление версии программного обеспечения на территории ОАО «ГИВЦ Москвы». По окончанию гарантийного срока Вы можете приобретать следующие версии Программы со скидкой. При приобретении лицензии на Программу у официального дилера ОАО «ГИВЦ Москвы» Вам предоставляется возможность получения вышеперечисленных услуг непосредственно у этого дилера. Список официальных дилеров ОАО «ГИВЦ Москвы» можно получить в «ГИВЦ Москвы». Другие услуги по поддержке Программы в течение гарантийного и послегарантийного сроков оплачиваются пользователем на договорной основе.
· Прекращение действия соглашения. Для защиты своих прав и законных интересов ОАО «ГИВЦ Москвы» может прекратить действие настоящего соглашения при несоблюдении условий и ограничений данного соглашения с Вашей стороны, что обяжет Вас уничтожить все имеющиеся копии и составляющие части Программы.
· Соблюдение действующего законодательства. Использование Программы должно осуществляться в соответствии с действующим законодательством.

4. АВТОРСКОЕ ПРАВО.

Правообладателем Программы является ОАО «ГИВЦ Москвы». Все права ОАО «ГИВЦ Москвы» на Программу защищены законами об авторских и смежных правах, а также другими законами и договорами, регулирующими отношения авторского права. КОПИРОВАНИЕ ПЕЧАТНЫХ МАТЕРИАЛОВ ЗАПРЕЩЕНО. ОАО «ГИВЦ Москвы» не предоставляет никаких прав иначе, чем явным о том утверждением. ОАО «ГИВЦ Москвы» гарантирует, что программа не затрагивает прав и законных интересов третьих лиц.

5. ОТКАЗ ОТ ГАРАНТИЙ.

Настоящим ОАО «ГИВЦ Москвы» и его уполномоченные лица явно отказывается от предоставления каких-либо гарантий по отношению к Программе. ПРОГРАММА И ВСЯ ОТНОСЯЩАЯСЯ К НЕЙ ДОКУМЕНТАЦИЯ ПРЕДОСТАВЛЯЕТСЯ "КАК ЕСТЬ", БЕЗ КАКОЙ-ЛИБО ГАРАНТИИ, ЯВНОЙ ИЛИ ПОДРАЗУМЕВАЕМОЙ, ВКЛЮЧАЯ ВСЕ БЕЗ ИСКЛЮЧЕНИЯ ПОДРАЗУМЕВАЕМЫЕ ГАРАНТИИ ТОВАРНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ КАКОЙ-ЛИБО ОПРЕДЕЛЕННОЙ ЦЕЛИ. ВЫ ПРИНИМАЕТЕ НА СЕБЯ ВЕСЬ РИСК, СВЯЗАННЫЙ С ИСПОЛЬЗОВАНИЕМ ИЛИ КАЧЕСТВОМ РАБОТЫ ПРОГРАММЫ.

6. ОГРАНИЧЕНИЕ СУММЫ ОТВЕТСТВЕННОСТИ.

В наибольшей степени, допускаемой действующим законодательством, ОАО «ГИВЦ Москвы» и его дилеры не несут ответственность за какой-либо ущерб, потерю прибыли, прерывание деловой активности, потерю деловой информации, моральный ущерб или любые другие убытки, связанные с использованием или невозможностью использования Программы, а также с непредоставлением или невозможностью предоставления услуг по технической поддержке, даже если ОАО «ГИВЦ Москвы» был заранее официально извещен о возможности таких потерь. В любом случае вся возможная совокупная ответственность ОАО «ГИВЦ Москвы» перед Вами не может превысить стоимости, уплаченной при покупке Программы.

7. РАЗНОЕ.

Стороны соглашаются с тем, что любое действие, нарушающее данное Лицензионное соглашение, должно быть наказуемо и преследуемо в соответствии с законодательством РФ.

При возникновении вопросов по данному соглашению или при необходимости связаться с представителями ОАО «ГИВЦ Москвы» по любому другому поводу обращайтесь по адресу: ОАО «ГИВЦ Москвы», 107078, г. Москва, ул. Каланчевская, 27.

Наш адрес в Интернет: www.iccm.ru, e-mail oasis@iccm.ru.


Об авторских правах
Previous Next

"Разработчик" считает необходимым напомнить, что в случае умышленного или случайного распространения программы, путем несанкционированной настройки на параметры сторонней организации, "Пользователь" несет ответственность за нарушение авторских прав "Разработчика" в соответствии с действующим законодательством, а "Разработчик" имеет право в одностороннем порядке прервать действие лицензии в части выполнения своих обязательств по гарантийному обслуживанию.


О Help-файле

При пользовании Help-файлом необходимо помнить о том, что программа постоянно совершенствуется и дорабатывается в соответствии с новыми нормативными и руководящими документами. В связи с этим видеоформы и описание работы могут незначительно отличаться от того, как это реализовано в конкретной версии, но без нарушения логики работы и без изменения выполняемых функций.


Функциональные возможности программы

КИС "Управление персоналом (администратор)" позволяет:

· вести список фирм (организаций) с указанием их подчинённости (в случае холдинговой структуры);
· определять возможные роли пользователей и права, предоставляемые им в соответствии с отведённой ролью;
· вести список пользователей системы;
· выполнять загрузку адресных справочников (Кладр);
· выполнять операции с базой данных (резервное копирование и восстановление БД);
· вести список событий, о которых необходимо напоминать пользователю.


Программно-технические требования

Программа поставляется в составе КИС "Управление персоналом" и может быть установлена на любой персональный компьютер, работающий под управлением операционной системы Windows'9х/ME/NT/2000/XP (Windows'95 только версии OSR2) и имеющий следующие технические характеристики:

Процессор – рекомендуется не ниже Pentium III
ОЗУ – рекомендуется не менее 64 Мб
Свободное пространство на жестком диске: - не менее 250 Мб (в случае полной установки)
Принтер – любой из используемых с данным компьютером.
Монитор - SVGA, рекомендуемое разрешение 1024х768, но не менее 800 x 600.
Видеокарта - не менее 256 цветов.

Дополнительные требования:

· убедитесь, что в настройках экрана установлен параметр "мелкий шрифт" (доступ: свойства "рабочего стола" (пункт меню на правой клавише мыши) - вкладка "настройка" - кнопка "дополнительно" - вкладка "Общие" - поле "размер шрифта").
· программа поставляется на компакт-дисках, поэтому для её установки требуется привод компакт-дисков (CD-ROM). Если компьютер работает в составе локальной сети и инсталляция может быть проведена с другого рабочего места, на данном компьютере привод компакт-дисков иметь не обязательно.
· для вывода данных на магнитный носитель в состав компьютера должен входить соответствующий накопитель. Если компьютер работает в составе локальной вычислительной сети, данные могут быть выведены на другой компьютер, имеющий в своем составе такой накопитель.

Установка и работа программы не требует никаких дополнительных приложений.

Для создания резервных копий данных необходимо иметь соответствующий привод для выбранного машинного носителя информации. Однако, если Вы работаете в сети, то достаточно наличие этих устройств на одном из Ваших компьютеров.


Запуск и подключение к БД, начало и завершение сеанса работы.

Запуск осуществляется либо двойным щелчком мыши на ярлыке "КИС Управление персоналом (администратор)", расположенном на рабочем столе, либо выбором команды "КИС Управление персоналом (администратор)", для чего - нажать кнопку "Пуск" на панели задач, выбрать в меню "Программы" пункт "Oasis" и в группе "КИС Управление персоналом" выбрать ранее указанную команду.

Работа начинается с вывода окна "Подключение" (рис. 1).

podkluchenie
рис. 1

В полях "Пользователь" и "Пароль" (окно "Подключение", рис. 1) укажите свое регистрационное имя и пароль. Первоначально имя и пароль задаются разработчиками программного продукта КИС "Управление персоналом" и сообщаются ответственному лицу (администратору программы) при установке / продаже. В дальнейшем администратор может "создавать / удалять" пользователей и менять их пароли. Обратитесь к администратору программы за сведениями о Вашем регистрационном имени и пароле, после чего введите их в соответствующие поля. В целях безопасности вместо имени отображаются звездочки.

Поле "Использовать аутентификацию Windows" предназначено для управления функцией разграничения доступа. Если в указанном поле есть отметка, то программа будет использовать для аутентификации пользователя Логин и пароль, использованные при загрузке компьютера. В противном случае - указанные в полях "Пользователь" и "Пароль".

Нажатие кнопки "Ок" инициирует подключение к БД и, если введенные Логин и пароль верны, открывается доступ к программе и БД. На экран выводится главное окно программы. Пользователь может начать сеанс работы.

После выполнения программных настроек и настройки прав доступа для пользователей, можно начинать работу с программным продуктом "КИС Управление персоналом".

Завершение работы происходит при нажатии стандартной кнопки, расположенной в правом верхнем углу главного окна программы.


Начальные сведения

Перед началом работы необходимо произвести предварительную настройку программного продукта, что важно для дальнейшей корректной и успешной работы.

Предварительная настройка выполняется с использованием средств, предоставляемых программой "КИС Управление персоналом (администратор)" и включает в себя:

· формирование списка организаций (должна быть, по меньшей мере, хотя бы одна организация);
· определение перечня типовых ролей;
· формирование списка пользователей и назначение им ролей;
· загрузка необходимых адресных справочников.

Резервное копирование базы данных и восстановление из резервной копии выполняется администратором по мере необходимости.


Роли

В программном продукте "КИС Управление персоналом" используется ролевой принцип назначения прав доступа. Это предполагает, что администратор продукта формирует набор типовых ролей, каждой из которых приписывается определённый набор прав, т.е. действий которые может выполнять пользователь в данной роли.

Нажмите кнопку [image] на панели инструментов главного окна. Откроется форма "Список ролей" (рис. 1), где приведён перечень ранее сформированных ролей. Изначально сформированы и не подлежат удалению три роли, информация о которых приведена на рис. 1.

spisok rolei
рис. 1

После нажатия кнопки [image] (добавить), открывается окно "Новая роль" (рис. 2), предназначенное для формирования новой роли. Укажите наименование роли и требуемый уровень прав администратора (последнее, при необходимости). Далее требуется определить права доступа, для чего последовательно выбирая объекты в левом полуокне (Объект системы, рис. 2), в правом укажите перечень разрешённых действий для каждого из объектов. Разрешённым считается действие, отмеченное флажком в графе "Разрешить" (рис. 2). Если при выборе объекта, справа не отображается перечень допустимых действий, значит данный объект используется без ограничений. Проверьте введённые данные и сохраните их .

novaya rol
рис. 2

Информация о новой роли отобразится в окне "Список ролей" (рис. 1).

Если в процессе работы возникнет необходимость изменить набор прав приписанных какой-то из ролей, выделите её и нажмите кнопку [image] (изменить). Откроется окно, приведённое на рис. 2, содержащее информацию о выбранной роли и поименованное как: "Роль: "Наименование роли" (редактирование)". Внесите требуемые изменения и сохраните информацию .

На панели инструментов окна "Список ролей" расположена кнопка [image], предназначеная для открытия диалога, позволяющего для выбранной роли (рис. 1) указать организацию и определить конкретному пользователю права (в соответствии с выбранной ролью) по доступу к отдельным структурным подразделениям данной организации. При нажатии на указанную кнопку открывается окно "Роль: "наименование роли"" (рис. 3).

roli polzovatelei
рис. 3

В поле "Организация" укажите ту, для которой будет выполняться назначение прав пользователей. Далее определите пользователя, установив флажок в графе "Разрешить". Сохраните введённую информацию , после чего можно приступать к выбору подразделений.

Нажмите кнопку [image] (рис. 3), откроется окно "Выбор подразделений" (рис. 4). Отметка в поле "Включая вложенные" означает, что при выборе какого-либо подразделения оно учитывается вместе со всеми внутренними подразделениями.

vibor podrazdelenii
рис. 4

Для выбора подразделения выделите его в левом полуокне и нажмите кнопку kn_strelka vpravo zel. Наименование подразделения отобразится в правом полуокне. Если по каким-либо причинам необходимо изменить состав выбранных подразделений, выделите то из них, которое необходимо убрать, и нажмите кнопку kn_strelka vlevo zel. Кнопка kn_strelka vlevo zel dv используется в тех случаях, когда необходимо вернуться к исходному состоянию, т.е. правое полуокно не содержит ни одного выбранного подразделения.

Чтобы ускорить процесс назначения прав доступа для новых ролей или изменения их для существующих, можно воспользоваться функцией "Копировать роль" (рис. 1). Если роль ещё не определена, создайте её не указывая права доступа. Выберите роль, для которой будут назначаться новые права, и нажмите кнопку "Копировать роль". На экран будет выведено сообщение (рис. 5), предупреждающее о том, что ранее назначенные права доступа для выбранной роли будут утеряны.

soobchenie
рис. 5

Подтвердите продолжение выполнения операции, после чего, в окне "Выбор роли для копирования" (рис. 6), укажите ту роль, чьи права будут использованы как образец, и нажмите кнопку "Выбрать".

vibor roli
рис. 6

Потом можно открыть данную роль в режиме редактирования и внести требуемые изменения.


Назначение прав пользователям

C целью обеспечения доступа должностных лиц только к той информации, которой они могут пользоваться в соответствии со своими должностными полномочиями, в программе предусмотрено разграничение доступа конкретных пользователей к ресурсам и видам действий, которые могут совершаться с данными ресурсами.

Разграничение доступа реализуется администратором программного продукта после запуска программы "КИС Управление персоналом (администратор)".

В нашем программном продукте реализован ролевой принцип разграничения доступа, т.е. формируется некий набор абстрактных ролей, каждой из которых соответствует определённый набор прав. Далее каждому из пользователей назначается одна из типовых ролей с заранее определённым перечнем прав.

Назначение прав доступа начинается с нажатия кнопки [image]. На экран выводится окно "Список пользователей системы" (рис. 1).

spisok polzovatelei
рис. 1

Для добавления, редактирования и удаления записей о пользователях используются кнопки [image], [image] и [image], соответственно.

Добавить нового пользователя. открывается окно "Новый пользователь" (рис. 2). Поля "Пользователь" и "Логин" формируются автоматически в процессе заполнения полей "Фамилия", "Имя" и "Отчество". Поле "Логин" можно в дальнейшем корректировать. Если данному пользователю назначается пароль, то становится доступным и поле "Подтверждение пароля", где необходимо повторить ввод устанавливаемого пароля. Администратор может назначить пользователю "Логин" из числа ранее заведённых. Для этого установите переключатель в группе "Использовать логин" в положение "Имеющийся" и выберите логин из числа отображаемых в группе "Список логинов".

novii polzovatel
рис. 2

Заполните поля формы и нажмите кнопку [image] для ввода информации, или [image] - в противном случае. Информация о новом пользователе отобразится в форме "Список пользователей системы" (рис. 1).

Изменение информации о текущем (выделенном пользователе). Выводит окно "Зарегистрировать: "Ф.И.О. пользователя"" с помощью которого можно изменить текущую информацию для выбранного пользователя. Форма "Зарегистрировать: "Ф.И.О. пользователя"" полностью аналогична форме "Новый пользователь" (рис. 2) с тем отличием, что поля заполнены ранее введённой информацией. Измените её, если необходимо и сохраните введённую информацию.

Удалить запись о пользователе. Удаляет информацию о выделенном (текущем пользователе) после подтверждения пользователем необходимости выполнения данного действия в ответ на запрос программы.

С помощью кнопок Заблокировать ( [image]) и Разблокировать ( [image]) администратор имеет возможность заблокировать и, соответственно, разблокировать работу пользователя в системе. Перед нажатием той или другой кнопки необходимо предварительно выделить пользователя над которым будет выполняться действие.

Роли ( [image]). Назначение ролей пользователям для отдельных подразделений организации.

Пароль ( [image]). Изменение пароля пользователя.


Изменение пароля

Чтобы изменить пароль пользователя, выделите соответствующую запись в окне "Список пользователей системы" и нажмите кнопку [image]. Откроется окно "Изменить пароль: "Ф.И.О. пользователя"" (рис. 1), где в поле "Новый пароль" необходимо ввести его значение, а ниже подтверждение пароля.

izmenit parol
рис. 1


Загрузка классификатора адресов

Выберите подпункт "Загрузить кладр" в меню открывающемся при нажатии на кнопку [image], расположенную правее кнопки [image]. В открывшемся окне "Загрузка адресных справочников" (рис. 1) нажмите кнопку "Указать папку".

рис. 1

Окно примет вид, приведённый на рис. 2. В группе "Настройки импорта" укажите путь к файлам KLADR (они располагаются на дистрибутивном диске) и путь к временным файлам (для этих целей подойдёт любая папка, но лучше создать новую, которую впоследствии можно удалить).

рис. 2

Нажатие кнопки "Выбор" изменяет окно, делая доступными кнопки "Загрузить регион" и "Загрузить всё" (рис. 3). Кнопка "Загрузить всё" позволяет сразу загрузить информацию за все регионы после утвердительного ответа на запрос программы.

рис. 3

Если же необходимо загрузить только один или несколько регионов, нажмите кнопку "Загрузить регион" и отметьте регионы, информацию о которых необходимо загрузить так, как это показано на рис. 4.

рис. 4

Кнопка "Выбор" (рис. 4) инициирует начало процесса загрузки, ход которого отображается с помощью указателя прогресса (рис. 5) и может продолжаться довольно длительное время. зависящее от количества загружаемых регионов.

рис. 5

После завершения загрузки становится доступной кнопка "Выгрузить регион" (рис. 6), которая предназначена для удаления информации о ранее загруженных регионах. Для выгрузки региона выделите его и нажмите кнопку "Выгрузить регион" (рис. 6), после чего подтвердите необходимость выполнения указанного действия в ответ на запрос программы.

рис. 6

Кнопка "Обновить регион" становится доступной в том случае, если есть загруженные регионы и указан путь к файлам KLADR и путь к временным файлам (рис. 2). Данная кнопка предназначена для обновления информации о регионе.


Сообщения о событиях

Данный режим позволяет определить события, информация о наступлении которых будет выводиться пользователям, которые определены в качестве получателей.

Выберите подпункт "Настроить сообщения о событиях" в меню открывающемся при нажатии на кнопку [image], расположенную правее кнопки [image]. В открывшемся окне "Настройка сообщений о событиях" (рис. 1) в поле "Фирма" укажите организацию для которой будет выполняться настройка.

nastroika soobschenii o sobitiyax
рис. 1

При этом в группе "Список уведомлений о событии" отобразится весь перечень событий, информация о которых может выводиться пользователям системы. В графе "Вид события" - указано наименование события, в графе "Дней" - задаётся за сколько дней до наступления события необходимо информировать пользователей об этом факте, а в графе "Вкл." - определяется принципиальная необходимость информирования о данном событии. По умолчанию включены все события.

Снимите отметки в графе "Вкл." напротив тех событий, информация о наступлении которых для Вас неинтересна. Для остальных событий установите количество дней до наступления каждого из событий, для информирования пользователей.

Пользователи, получающие сообщения о наступлении события определяются раздельно для каждого события. Чтобы определить перечень пользователей для выбранного события, нажмите кнопку [image] и в открывшемся окне "Выбор ролей" (рис. 2) выберите из списка ролей те, которые будут информироваться о наступлении выбранного события.

рис. 2

Чтобы выбрать роль выделите её в группе "Список ролей для выбора" и нажмите кнопку kn_strelka vpravo zel. Для исключения роли из числа выбранных, выделите её в группе "Выбранные роли" и нажмите кнопку kn_strelka vlevo zel. По окончании формирования списка выбранных ролей нажмите кнопку "Выбор".

Завершение формирования списка событий происходит после закрытия окна "Настройка сообщений о событиях".


Главная панель инструментов программы

На главной панели инструментов представлены кнопки для выполнения наиболее часто требуемых действий (рис. 1).

glavnaya panel instrumentov
рис. 1

Организации
Ввод сведений об организациях.

Пользователи
Открывается форма позволяющая вводить, изменять и удалять пользователей системы, а также назначать им типовые права.

Роли
Показывает список типовых ролей, используемых в системе. Позволяет вводить новые, редактировать и удалять существующие роли.

Настройка
Выполнение функций, связанных с загрузкой адресных справочников; обслуживанием базы данных (резервное копирование и восстановление); задание событий, о наступлении которых должно выдаваться сообщение пользователю; создание скрипта базы данных.


Основные кнопки управления, используемые в программе

- Добавить запись

- Изменить запись

- Удалить запись

- Сохранить изменения

- Отменить изменения

или [image] - Закрыть окно

-перечитать (обновить) данные


Изменение порядка следования столбцов в видеоформах

Этот сервис позволяет произвести индивидуальную настройку ряда форм (но не всех) и удобен в случае, когда пользователю необходимо изменить взаимное расположение столбцов в любой из форм исходя из удобства работы с ней или по каким-либо иным причинам.

Ниже, на примере табличной формы, отображаемой при выводе на экран окна для работы с адресными справочниками (рис. 1), показан механизм изменения порядка следования столбцов.

Установите курсор на наименовании столбца, местоположение которого необходимо изменить, нажмите левую клавишу мыши и "тащите" (рис. 1) наименование столбца в то место, где он должен быть. По мере движения между наименованиями столбцов будут отображаться две, направленные друг к другу, стрелки зелёного цвета (рис. 1), показывающие место, куда будет вставлен столбец, если отпустить левую клавишу мыши в данный момент времени.

рис. 1

На рис. 1 и рис. 2 приведён пример изменения местоположения столбца "Тип объекта". "Захваченное" наименование столбца перетаскивается к новой позиции - между столбцами "Загружен" и "Дата загрузки" (рис. 1) и затем, после появления стрелок, обозначающих место, куда он может быть вставлен, левая клавиша мыши отпускается. Результат действия - столбец "Тип объекта" размещается за столбцом "Загружен" (рис. 2). Новое расположение столбцов запоминается и в дальнейшем используется "по умолчанию".

рис. 2


Программа не устанавливается, не запускается или окна программы и меню не размещаются в пределах экрана

Проверьте технические возможности Вашего компьютера. Должны выполняться следующие требования:

· наличие не менее 128 Мб оперативной памяти;
· наличие не менее 250 Мб свободного дискового пространства на жестком диске;
· наличие монитора и видеокарты, обеспечивающие разрешение не менее 800*600;
· наличие привода CD-ROM - для развертывания прикладного программного обеспечения на локальном компьютере, не подключенном к ЛВС или сетям общего пользования;
· программная среда поддерживается Windows NT/2000/XP.


Не удается установить соединение с БД

Если не удается установить соединение с базой данных и начать работу, проверьте:

· правильность указываемых, в соответствующих полях, значений идентификационного имени и пароля;
· вероятность "неправильной раскладки" клавиатуры;
· у администратора программного продукта - правильность используемых идентификационного имени и пароля;

или попробуйте переустановить программу, предварительно удалив действующую копию последовательным выбором следующих пунктов выпадающего меню: "Пуск" (кнопка в левой нижнем углу экрана), "Программы", "Оasis", "КИС Управление персоналом", "Удалить программу".


Отдельные формы программы не отображаются на экране, компьютер зависает.
Previous

Проверьте технические параметры видеокарты (она должна обеспечивать разрешение не менее 800 х 600) и убедитесь, что на компьютере установлены "родные" драйвера для видеокарты. Технические параметры видеокарты должны удовлетворять требованиям, установленным разработчиком. Драйвер видеокарты также должен обеспечивать выполнение заданных требований.


Дополнительные сведения об организации

Ввод дополнительных сведений (параметров), которые могут использоваться при формировании выходных документов.

Доступ: подпункт "Дополнительные сведения", после нажатия на кнопку [image], расположенную справа от кнопки "Организации".

Открывается окно "Список дополнительных сведений по организации" (рис. 1), которое содержит перечень сведений об организации, которые используются в программе для формирования, в частности, выходных документов.

dopolnit svedeniya
рис. 1

Изначально этот перечень состоит из 21 параметра, которые не могут быть изменены или удалены пользователем. Пользователь может только добавить новые и удалить те, которые ранее были им же и введены.

Для добавления и удаления используются кнопки [image] и [image], соответственно.

Добавить
Занесение информации о новом параметре. При нажатии в рабочей области окна отображается новая строка. Устанавливая курсор в соответствующие графы, заполните их.

Чтобы отредактировать наименование параметра или его номер - просто установите курсор в данное поле и щелкните левой клавишей мыши, после чего введите новое значение.

Удалить
Удаление информации о параметре, которая содержится в выбранной строке (рис.1).

Завершение работы с формой происходит после нажатия кнопки [image].


Мини-календарь для ввода дат

Поля, в которых предусмотрен ввод дат, могут быть либо заполнены вручную, либо путем выбора даты из встроенного календаря, что возможно после нажатия на кнопку [image], расположенную в правой части соответствующего поля.

В последнем случае выводится окошко, представленное ниже:

Вверху указаны выбранные месяц и год, внизу представлены дни (числа) недели в соответствии с выбранным годом и месяцем.

В левом и правом верхних углах расположены кнопки:
- на месяц назад
- на месяц вперед

Кнопка "Сегодня" предназначена для ввода текущей даты в соответствующее поле, а при нажатии на кнопку "Очистить" производится очистка поля.

Если установить курсор на наименовании месяца и нажать левую клавишу мыши, то откроется список из трёх месяцев до текущего и трёх после. Это сделано для удобства перехода к ближайшим месяцам.

Найдите необходимую дату, "щелкните на ней" левой кнопкой мыши и ее значение подставится в поле.


Восстановление базы данных из резервной копии

Некорректная работа с компьютером и аварийные ситуации, которые возникают при эксплуатации аппаратных средств (например, отключение электропитания), могут привести к повреждению базы данных. В результате некоторые данные и функциональные возможности программы могут стать недоступными.

Для восстановления БД перейдите к вкладке "Восстановление".

nastroika soxraneniya bd_2
рис. 2

Укажите путь к архиву, содержащему БД, и нажмите кнопку "Выполнить". При задании пути к архиву можно воспользоваться кнопкой [image], расположенной в правой части поля, с помощью которой открывается стандартное окно "Открыть" для указания пути.


Резервное копирование базы данных

Чтобы иметь возможность оперативно восстановить работоспособность "КИС Управление персоналом" и минимизировать возможные потери данных, используется резервное копирование. Суть резервного копирования заключается в том, что база данных регулярно сохраняется в виде файла специального формата (резервной копии).

При этом рекомендуется хранить резервные копии на магнитном носителе, отличном от того, на котором размещена база данных, т.к. если резервные копии хранятся на том же диске, что и база данных, выход из строя диска может привести к полной потере всех данных.

Основной вопрос резервного копирования - как часто делать резервные копии: каждый день, через день, раз в несколько дней и т.д. Это зависит от нескольких факторов:
1). Надежность работы оборудования.
2). Как часто и в каком объеме вводятся данные.
3). Объем базы данных и объем накопителя для хранения резервных копий.

Рекомендуется хранить состояния базы данных за текущий и предыдущий месяцы. После завершения текущего месяца копии базы предыдущего можно удалить.

Чтобы различать копии и иметь возможность их упорядочения, рекомендуется присваивать им имена в виде даты сохранения, например, в виде 8-разрядного десятичного кода, в котором первые 4 разряда отводятся под год, следующие 2 - под месяц, и последние 2 - под число (20001015 - 15 октября 2000 г.).

При принятии решения о периодичности резервного копирования следует иметь в виду, что, если после сохранения самой новой копии в базу вводились данные (или изменялись), в случае повреждения базы эти данные (или изменения), возможно, придётся восстанавливать вручную.

Резервная копия БД может быть создана пользователем, имеющим права администратора.

Выберите подпункт "Обслуживание базы данных" в меню открывающемся при нажатии на кнопку [image], расположенную правее кнопки [image]. Откроется окно "Настройка сохранения БД" (рис. 1).

nastroika soxraneniya bd_1
рис. 1

Создание резервной копии сводится к указанию значений в реквизитах: "Путь архива", "Имя задачи" и "Описание".

Укажите требуемые значения и нажмите кнопку "Выполнить" (рис. 1). При задании пути к архиву можно воспользоваться кнопкой [image], расположенной в правой части поля, с помощью которой открывается стандартное окно "Открыть" для указания пути.

Администратором должен быть установлен и соблюдаться единый порядок создания и хранения резервных копий (порядок присвоения имени и определения места хранения).

Помните, что резервное копирование, хоть и требует определенных усилий и времени, однако они несоизмеримы с затратами в случае потери данных из-за неисправности компьютера, неполадок в электросети или других причин.


Создание резервной копии базы данных по расписанию

Если администратор программного продукта считает целесообразным выполнять резервное копирование базы данных регулярно и автоматически, целесообразно установить порядок создания резервной копии, используя вкладку "Расписание" (рис. 1) формы "Настройка сохранения БД" (доступ: подпункт "Обслуживание базы данных" в меню открывающемся при нажатии на кнопку [image], расположенную правее кнопки [image]).

Вкладка "Расписание", в свою очередь, включает ещё две вкладки: "Основные настройки" (рис. 1) и "Настройки расписания" (рис. 2).

nastroika soxraneniya bd_3
рис. 1

Заполните реквизиты вкладки "Основные настройки", обратив внимание на поля "Дата" и "Время". Резервное копирование базы данных будет выполняться согласно расписанию вназначенное время, начиная с указанной даты.

Перейдите на вкладку "Настройки расписания" (рис. 2) и задайте типовой график создания резервной копии. В зависимости от положения переключателя в группе "Условия" вкладка "Настройки расписания" принимает вид, приведённый на рис. 2, 3 и 4. Укажите периодичность создания резервной копии и нажмите кнопку "Выполнить".

nastroika soxraneniya bd_5
рис. 2

nastroika soxraneniya bd_4
рис. 3

nastroika soxraneniya bd_6
рис. 4


Создание скрипта базы данных

При возникновении проблем с базой данных, для адекватной оценки возникшей ситуации, разработчику может потребоваться скрипт базы. Для создания скрипта нажмите кнопку [image], расположенную правее кнопки [image], после чего в открывшемся окне "Создание скрипта базы данных" (рис. 1) укажите путь к файлу скрипта. Чтобы облегчить процесс указания пути, используйте кнопку [image].

sozdanie scripta bd
рис. 1

Операция завершается нажатием кнопки "Создать". Процесс создания будет отображаться с помощью указателя прогресса. По окончании нажмите кнопку "Закрыть".


Список организаций

Перед началом работы необходимо ввести перечень организаций (в случае холдинговой структуры, соблюдая их внутреннюю иерархию), по которым будет вестись информация в базе данных. Нажмите кнопку [image], откроется одноимённое окно (рис. 1).

organizacii
рис. 1

Чтобы добавить новую организацию в список воспользуйтесь кнопкой [image], а для редактирования информации о существующей - выделите её и нажмите кнопку [image]. Обе кнопки расположены на панели инструментов окна "Организации" (рис. 1). В обоих случаях открывается окно, имеющее вид, приведённый на рис. 2. Единственное отличие: в случае редактирования, все поля заполнены ранее введённой информацией.

dobavit organizaciu
рис. 2

Заполните (отредактируйте) значения в полях формы и сохраните введённую информацию. Кнопка [image] на панели инструментов окна. В случае, если необходимость ввода сведений отпала - закройте окно или нажмите кнопку [image]. Информация о вновь введённой организации отобразится в окне "Организации" (рис. 3).

organizacii spisok
рис. 3

Если вводится информация об организации, входящей в холдинговую структуру, обязательно укажите наименование организации, которой подчиняется данная (реквизит "Вышестоящая организация", рис. 2).

Чтобы удалить какую-либо организацию из списка, выделите её и нажмите кнопку [image], после чего подтвердите необходимость выполнения указанного действия в ответ на запрос программы.